Banner 1

instalando Metasploit 3.1 en Ubuntu

Bueno despues de tener sonido en mi ubuntu me coloque en la accion de tunearlo y que mejor forma que instalando metasploit xD

Primero que nada, para instalar correctamente en ubuntu, tenemos que seguir los siguientes pasos:

Bajar el metasploit:
1. Bajarnos el tarball de acá: http://www.metasploit.com/framework/download/

y descargamos framework-3.1.tar.gz
2. Descomprimirlo:
tar xzvf framework-3.1.tar.gz

Dependencias rubygems:
3. Abrimos una consola e instalamos:
apt-get install ruby libruby rdoc
apt-get install libyaml-ruby
apt-get install libzlib-ruby
apt-get install libopenssl-ruby
apt-get install libdl-ruby
apt-get install libreadline-ruby
apt-get install libiconv-ruby
apt-get install libgtk2-ruby libglade2-ruby
apt-get install rubygems *


Ejecutar (Instalar) Metasploit:


Accedemos al directorio donde hayamos descomprimido el metasploit y ejecutamos el que queramos...


Modo consola: ./msfconsole Este modo nos carga en la misma terminal la consola del metasploit

Modo consola web: ./msfweb Este modo nos carga un localhost, donde se cargan todos los payloads, una vez ejecutada esta opcion podemos acceder desde cualquier navegador en la direccion 127.0.0.1:55555


Modo gui: ./msfgui
Este modo nos carga la consola del metasploit en un entorno gtk para gnome.


Y listo! tenemos corriendo metasploit en sus distintas formas.. usa la que mas te guste ya sea web, consola o gui... espero les haya gustado este poste, luego voy a postear una guia introductoria a su uso.

FUENTE:http://grk-t.blogspot.com/2008/11/metasploit-31-en-ubuntu.html

2 comentarios:

Powered by Bad Robot
Helped by Blackubay